Aside

Self-hosting File Browser on OpenBSD

Background

I mentioned previously that I am self-hosting Syncthing for syncing my files to multiple devices and the cloud. I also wanted to access my cloud files via web browser, so I'm self-hosting File Browser as well.

These are the steps I took to set up File Browser on OpenBSD 7.6 x64, including some of the larger errors I encountered and what I did to solve (or work around) them. Building from source was... an experience. (This GitHub comment made it seem so simple. 🙃)

Newbie lesson learned: My 1 GB memory server could not build from source, so I spun up a separate 4 GB memory server to build the binary, then transferred the binary back to my original server. (I learned what a binary is from this process.)

I referred to a bunch of guides & documentation while installing this, which I'm listing below in References. Email me suggestions for improvements.

What I did

Below, when I mention $user, it's a placeholder for actual username (can find username with echo $USER). Every step that has only text styled like this means that I typed/pasted it into PowerShell and pressed enter afterwards. When I use mg to edit a file, I save & exit by pressing ctrl + x, then ctrl + c (to exit), then y to save changes.

Attempt to build File Browser (and fail)

tl;dr — Not enough memory, copy source files over to new server, build, copy binary back to original server.
  1. ssh $user@server-ip-address
  2. Install these things to build from source (I added these individually as I saw errors, but compiled them together here in the beginning)
    1. doas pkg_add gmake node go
    2. doas pkg_add git
    3. doas pkg_add bash
    4. doas npm install -g pnpm
  3. Build from source
    1. git clone https://github.com/filebrowser/filebrowser
    2. cd filebrowser
    3. gmake build
    4. See error:
Error: Your current platform "openbsd" and architecture "x64" combination is not yet supported by the native Rollup build. Please use the WASM build "@rollup/wasm-node" instead.

...

Node.js v20.18.2
 ELIFECYCLE  Command failed with exit code 1.
gmake: *** [Makefile:13: build-frontend] Error 1
  1. Address the error by installing the WASM build
    1. cd ~/filebrowser/frontend
    2. pnpm add -D @rollup/wasm-node
  2. Add override to package.json (I did this via SFTP because I didn't want to do edits via command line anymore)
    1. SFTP into server with WinSCP
    2. Right-click and duplicate /filebrowser/frontend/package.json to save a backup copy
    3. Right-click and edit package.json
    4. Add "pnpm" override between "engines" section and "scripts" section:
  "engines": {
    ...
  },
  "pnpm": {
    "overrides": {
    "rollup": "npm:@rollup/wasm-node"
    }
  },
  "scripts": {
    ...
  },
  1. Add override to pnpm-lock.yaml
    1. Right-click and duplicate /filebrowser/frontend/pnpm-lock.yaml to save a backup copy
    2. cd ~/filebrowser/frontend
    3. pnpm install --no-frozen-lockfile
  2. Try to build again
    1. cd ~/filebrowser
    2. gmake build
    3. See new error:
✓ 1140 modules transformed.

<--- Last few GCs --->

[44534:0x4326d372000]    42338 ms: Mark-Compact 494.1 (515.4) -> 490.2 (515.7) MB, 1121.35 / 0.00 ms  (average mu = 0.095, current mu = 0.037) allocation failure; scavenge might not succeed
[44534:0x4326d372000]    43487 ms: Mark-Compact 494.1 (515.7) -> 490.2 (515.7) MB, 1131.97 / 0.00 ms  (average mu = 0.059, current mu = 0.014) allocation failure; scavenge might not succeed


<--- JS stacktrace --->

FATAL ERROR: Ineffective mark-compacts near heap limit Allocation failed - JavaScript heap out of memory
----- Native stack trace -----

...

Abort trap (core dumped)
 ELIFECYCLE  Command failed with exit code 134.
gmake: *** [Makefile:13: build-frontend] Error 134
  1. Spend way too long trying to address the memory error in various ways but ultimately accept that 1 GB memory is not enough to build this thing

Create new server with 4 GB memory

I wanted to temporarily upgrade my server's memory and then downgrade it later, but that wasn't a possibility. So spinning up a second $20/mo server it is. I'll destroy it after I'm done. If we throw enough money at the problem, it'll get solved, right? (The 4 GB server costed $2.71 at the time of destruction, since I ran it only for a couple days.)

  1. Log into Vultr.com
  2. Go to Products > Compute > Deploy +
  3. Select Shared CPU > Select the same city as other server
  4. Select 4 GB memory for $20/mo
  5. Disable Automatic Backups and confirm that yes, I understand the risks and really don't want it
  6. Select Configure Software
  7. Select OpenBSD 7.6 x64 (the blowfish again)
  8. Under SSH Keys, select mykey
  9. Leave server hostname and server label blank
  10. Select Deploy

SSH into root & run Tech Independence script again

I just wanted to use the script to set up SSH access & disable root account. One day I'll learn how to do this on my own.

  1. ssh root@4gb-server-ip
  2. yes
  3. ftp https://sive.rs/ti.sh
  4. sh ti.sh
  5. Enter my domain name
  6. Enter a username
  7. y
  8. Enter a full name
  9. Enter a password
  10. Retype password
  11. Open a new PowerShell window
    1. ssh $user@4gb-server-ip
    2. And then again per the instructions, ssh $user@4gb-server-ip
  12. Close out of both PowerShell windows

Mirror files from original server to new server

I ended up doing this because I set up the 4gb-server the next night, and one of the node modules updated 14 hours before my second install. That module update caused new errors that I didn't want to spend time troubleshooting. Since I knew my first install was building just fine, I decided to clone it over.

  1. Open FreeFileSync (because I didn't know how to use Rsync yet)
  2. On the left, add 1gb-server's SFTP login info
  3. On the right, add 4gb-server's SFTP login info
  4. Select the green gear icon
  5. Go to Comparison tab and Performance improvements on the right
    • Update Parallel file operations to 4 for each server (requires donation edition of app; I didn't know about this setting when I started my sync and things were painfully slow since there were so many tiny files — I ran the sync overnight)
  6. Go to Synchronization tab
    • Under Delete and overwrite:, select Permanent (because there is no Recycle Bin on the server)
  7. Use FreeFileSync to mirror /filebrowser directory from original server to new server
    1. Under Drag & drop for both sides, ensure the path is /home/$user/filebrowser
    2. Select Synchronize
    3. Wait for it to complete

Build File Browser on new server (and succeed)

  1. ssh $user@4gb-server-ip
  2. Install these things to build from source (same as before)
    • doas pkg_add gmake node go
    • doas pkg_add git
    • doas pkg_add bash
    • doas npm install -g pnpm
  3. cd filebrowser
  4. gmake build
  5. See new error:
failed to load config from /home/$user/filebrowser/frontend/vite.config.ts
error during build:
Error: The service was stopped: spawn /home/$user/filebrowser/frontend/node_modules/.pnpm/@esbuild+openbsd-x64@0.24.2/node_modules/@esbuild/openbsd-x64/bin/esbuild EACCES
    at /home/$user/filebrowser/frontend/node_modules/.pnpm/esbuild@0.24.2/node_modules/esbuild/lib/main.js:968:34
    at responseCallbacks.<computed> (/home/$user/filebrowser/frontend/node_modules/.pnpm/esbuild@0.24.2/node_modules/esbuild/lib/main.js:622:9)
    at ChildProcess.afterClose (/home/$user/filebrowser/frontend/node_modules/.pnpm/esbuild@0.24.2/node_modules/esbuild/lib/main.js:613:28)
    at ChildProcess.emit (node:events:518:28)
    at ChildProcess._handle.onexit (node:internal/child_process:291:12)
    at onErrorNT (node:internal/child_process:483:16)
    at process.processTicksAndRejections (node:internal/process/task_queues:82:21)
 ELIFECYCLE  Command failed with exit code 1.
gmake: *** [Makefile:13: build-frontend] Error 1
  1. Apparently a permission issue. Grant it permission to execute:
    • chmod +x /home/$user/filebrowser/frontend/node_modules/.pnpm/@esbuild+openbsd-x64@0.24.2/node_modules/@esbuild/openbsd-x64/bin/esbuild
  2. gmake build
  3. See new error:
✓ 1140 modules transformed.
rendering chunks (1)...Segmentation fault
 ELIFECYCLE  Command failed with exit code 139.
gmake: *** [Makefile:13: build-frontend] Error 139
  1. Okay, so error 139 is another memory issue. Check my user's memory limits:
    1. ulimit -a
    2. See that data(kbytes) is set to 1572864 KB (1.5 GB)
    3. Increase to 3 GB
      • ulimit -d 3145728
  2. gmake build
  3. IT'S BUILT! I never thought I'd get here

Temporarily run File Browser

  1. ~/filebrowser/filebrowser -r ~/files
  2. It's running on local host: Listening on 127.0.0.1:8080
  3. Leave this window open (closing it will stop running File Browser)
  4. Open a new PowerShell window and SSH into 4gb-server
    • Confirm that it's running
      1. netstat -an | grep 8080
      2. Should see:
tcp   0   0   127.0.0.1.8080   *.*   LISTEN
  1. Since it's running on localhost (127.0.0.1:8080) and I want to access it from my local computer
    1. Open a new PowerShell window
    2. ssh -L 8080:127.0.0.1:8080 $user@4gb-server-ip
    3. Open my Firefox browser
    4. Go to http://127.0.0.1:8080
    5. IT WORKS! happy dance
  2. Close all the windows

Now I just need to get this back to my 1 GB server.

Set up Rsync & copy the binary back to original server

  1. PowerShell window 1: Generate a new SSH key for 4gb-server
    1. ssh-keygen -t ed25519 -C "your-email@example.com"
    2. enter
    3. enter
    4. Confirm key was generated
      • ls -la ~/.ssh/id_*
    5. View SSH key
      • cat ~/.ssh/id_ed25519.pub
  2. New PowerShell window 2: Give 4gb-server access to 1gb-server
    1. ssh $user@1gb-server-ip
    2. doas mg ~/.ssh/authorized_keys
    3. Copy the public key from PowerShell window 1
      • Starts with ssh-ed25519
    4. Paste it it into the authorized_keys file and save the file
  3. PowerShell window 1: Log into 1gb-server from 4gb-server
    1. ssh $user@1gb-server-ip
    2. yes
    3. We're in!
    4. exit
    5. Copy the binary from 4gb-server to 1gb-server
      • rsync -avz ~/filebrowser/filebrowser $user@1gb-server-ip:/home/$user/filebrowser/
  4. PowerShell window 2: Remove 4gb-server's access
    1. doas mg ~/.ssh/authorized_keys
    2. Delete the key we added earlier and save the file
  5. Close window 1; done with the 4gb-server now and no longer need to log into it again

Get the binary

I'm sharing the binary for those who would prefer not to build from source. (Please be cautious about such things.)

  1. Pull the binary file
    • ftp https://eeeee.lol/pub/filebrowser2.32-openbsd7.6.tar.gz
  2. Rename the file and remove the tar.gz extension
    • mv filebrowser2.32-openbsd7.6.tar.gz filebrowser
  3. Make the filebrowser directory & move the binary in
    • cd
    • mkdir ~/filebrowser
    • mv filebrowser ~/filebrowser/

Run File Browser on original server

  1. Update permissions so that the binary can be executed
    • chmod +x ~/filebrowser/filebrowser
  2. Confirm that it runs properly after the copy
    1. ~/filebrowser/filebrowser
    2. Should see this error since port 8080 is already taken:
2025/03/21 05:01:33 Warning: filebrowser.db can't be found. Initialing in /home/$user/filebrowser/
2025/03/21 05:01:33 Using database: /home/$user/filebrowser/filebrowser.db
2025/03/21 05:01:33 No config file used
2025/03/21 05:01:33 listen tcp 127.0.0.1:8080: bind: address already in use
  1. Assign IP and set port to 8082
    1. cd ~/filebrowser
    2. rm ~/filebrowser/filebrowser.db
    3. ~/filebrowser/filebrowser config init -a '127.0.0.1'
    4. ~/filebrowser/filebrowser users add username password --perm.admin
      • Since we just deleted the database, we need to recreate an admin — this is for logging into the File Browser web GUI
      • username should be a new unique username
      • password should be a new unique generated password
    5. ~/filebrowser/filebrowser config set -p '8082'
    6. Should see:
Server:
...
  Port:          8082
...
  Address:       127.0.0.1
  1. Run File Browser and confirm it works as expected
    1. ~/filebrowser/filebrowser
    2. Should see: Listening on 127.0.0.1:8082
  2. Close the window

Set up File Browser as a service

  1. Create a new _filebrowser daemon user
    • doas useradd -g =uid -s /sbin/nologin -d /nonexistent _filebrowser
  2. Move File Browser to /usr/local/bin with the other executable binaries and make root the owner
    1. doas mv ~/filebrowser/filebrowser /usr/local/bin/
    2. doas chown root:wheel /usr/local/bin/filebrowser
  3. Move filebrowser.db to /var/db with the other dbs
    1. doas mkdir -p /var/db/filebrowser
    2. doas mv ~/filebrowser/filebrowser.db /var/db/filebrowser/
  4. Update permissions to db
    1. doas chown _filebrowser:$user /var/db/filebrowser/filebrowser.db
    2. doas chmod 660 /var/db/filebrowser/filebrowser.db
    3. doas chown _filebrowser:$user /var/db/filebrowser/
    4. doas chmod 770 /var/db/filebrowser
  5. Give File Browser access to /mnt (same group as in Syncthing setup)
    1. doas usermod -G storagegroup _filebrowser
    2. id _filebrowser
    3. See the group on the list: 9999(storagegroup)
  6. Confirm File Browser still runs after all these changes
    • filebrowser -d /var/db/filebrowser/filebrowser.db -r /mnt
      • -d specifies which db it should use
      • -r specifies what folder it should display
  7. Create a rc.d service script (modeled after the Miniflux and Syncthing versions of the same file)
    1. doas mg /etc/rc.d/filebrowser
    2. Add the following info and save:
#!/bin/ksh

daemon="/usr/local/bin/filebrowser"
daemon_user="_filebrowser"
daemon_flags="-d /var/db/filebrowser/filebrowser.db -r /mnt"

. /etc/rc.d/rc.subr

rc_bg=YES
rc_reload=NO

rc_cmd $1
  1. Update permissions so it's executable
    • doas chmod +x /etc/rc.d/filebrowser

Run File Browser as a service

  1. doas rcctl enable filebrowser
  2. doas rcctl start filebrowser
  3. Should see: filebrowser(ok)
  4. IT'S ALIVE
  5. Update permissions now that the daemon will run things moving forward
    1. doas chown _filebrowser:_filebrowser /var/db/filebrowser/filebrowser.db
    2. doas chown _filebrowser:_filebrowser /var/db/filebrowser/
    3. doas chmod 740 /var/db/filebrowser/filebrowser.db
    4. doas chmod 750 /var/db/filebrowser
  6. Update permissions for sync directory, so File Browser has access to /mnt in the ways it needs
    1. doas chmod 770 /mnt
    2. doas chmod g+s /mnt
    3. find /mnt -type d -exec doas chmod 770 {} +
    4. find /mnt -type d -exec doas chmod g+s {} +
    5. find /mnt -type f -exec doas chmod 660 {} +
  7. Check permissions for folders and files
    1. ls -ld directoryname
      • Should see: drwxrws---
      • Read + write + execute
    2. ls -l filename
      • Should see: -rw-rw----
      • Read + write

Set up subdomain + security certificate

  1. Set up filebrowser.example.com subdomain
    • doas mg /etc/relayd.conf
      • Add table <filebrowser> { 127.0.0.1 } to the existing list
      • Add pass request quick header "Host" value "filebrowser.example.com" forward to <filebrowser> to the existing list
      • Add forward to <filebrowser> port 8082 to the existing list
  2. Set up security certificate for filebrowser.example.com subdomain
    • doas mg /etc/acme-client.conf
      • Add filebrowser.example.com
  3. Update and apply new security certificate
    • doas su
    • domain=yourdomain.com
    • acme-client -v $domain
    • rcctl restart relayd

Access File Browser via web GUI

  1. Go to filebrowser.example.com
  2. Log in with the username and password we created earlier
  3. Create new test folder and test file
  4. Confirm new folder and file are in /mnt
    1. find /mnt
    2. See them listed

Clean up my servers

tl;dr — Delete everything!
  1. Destroy 4gb-server on Vultr.com
  2. Remove all those things I installed to build from source on 1gb-server
    1. doas pkg_delete gmake node go git bash
    2. See note:
--- -git-2.46.1 -------------------
You should also run /usr/sbin/userdel _gitdaemon
You should also run /usr/sbin/groupdel _gitdaemon
--- -node-20.18.2v0 -------------------
You may wish to remove /usr/local/lib/node_modules/npm/man from man.conf
Error deleting directory /usr/local/lib/node_modules: Directory not empty
  1. Remove lingering files
    1. doas /usr/sbin/userdel _gitdaemon
    2. doas /usr/sbin/groupdel _gitdaemon
    3. doas rm -rf /usr/local/lib/node_modules
    4. rm -rf ~/.npm
    5. rm -rf ~/.cache/pnpm
    6. doas rm -rf ~/go
    7. rm -rf ~/.local/share/pnpm
    8. rm -rf ~/.local/state/pnpm
    9. rm -rf ~/.cache/pnpm
    10. rm -rf ~/.cache/go-build
    11. rm -rf ~/filebrowser

References

I ran a lot of searches on error codes; I haven't included all the pages I looked at, only the ones that helped with errors or provided other useful information. I also used ChatGPT as a "thought partner" to better understand the errors I was seeing and my options for troubleshooting.

Notes