Self-hosting Syncthing on OpenBSD
Background
I set up 40gb of storage ($1/mo) on a remote server ($5/mo) through the Tech Independence guide, but the only way to access it was via FreeFileSync or WinSCP, and I don't care for either of these apps. I wanted a Dropbox / Google Drive-like experience where my files are available on multiple devices and automatically sync to the cloud. So I decided to achieve this with Syncthing and File Browser.
(See follow-up notes at: Self-hosting File Browser on OpenBSD.)
I referred to a bunch of guides & documentation while installing this, which I'm listing below in References. Email me suggestions for improvements.
What I did
Every step that has only text styled like this
means that I typed/pasted it into PowerShell and pressed enter afterwards. When I use mg
to edit a file, I save & exit by pressing ctrl + x, then ctrl + c (to exit), then y to save changes.
Install Syncthing on server
- SSH into server
ssh username@server-ip-address
doas pkg_add syncthing
- There was a warning, but I moved on
doas rcctl enable syncthing
doas rcctl start syncthing
- Increase maximum open files for Syncthing
doas mg /etc/login.conf
- Add to the bottom:
syncthing:\
:openfiles-max=60000:\
:tc=daemon:
doas cap_mkdb /etc/login.conf
doas mg /etc/sysctl.conf
- Add to the bottom:
kern.maxfiles=80000
sysctl kern.maxfiles=80000
doas mg /etc/rc.d/syncthing
- Add
-gui-address=127.0.0.1:8384
todaemon_flags
:
- Add
daemon_flags="-no-browser -gui-address=127.0.0.1:8384"
doas -u _syncthing -- syncthing -paths
- Find path for config.xml
doas mg path/to/syncthing/config.xml
- Find
<gui enabled="true" ... >
line - Add
<insecureSkipHostcheck>true</insecureSkipHostcheck>
to the section
- Find
Set up subdomain + security certificate
- Set up syncthing.example.com subdomain
- +
doas mg /etc/relayd.conf
- Add
table <syncthing> { 127.0.0.1 }
to the existing list - Add
pass request quick header "Host" value "syncthing.example.com" forward to <syncthing>
to the existing list - Add
forward to <syncthing> port 8384
to the existing list
- Add
- +
- Set up security certificate for syncthing.example.com subdomain
doas mg /etc/acme-client.conf
- Add
syncthing.example.com
- Add
- Update and apply new security certificate
doas su
domain=yourdomain.com
acme-client -v $domain
rcctl restart relayd
rcctl restart syncthing
Set up Syncthing's web GUI
Very important! Anyone can access this Syncthing website until authentication is set up.
- Go to syncthing.yourdomain.com
- Go to Settings > GUI
- Create GUI Authentication User and generate GUI Authentication Password
- Tick the box for Use HTTPS for GUI
- Select Save
Give Syncthing access to /mnt
- Go back to PowerShell
- Create a new shared group
doas groupadd storagegroup
- Add my user + Syncthing user to the new shared group
- Confirm username with
echo $USER
, then replace $user in below steps with username doas usermod -G storagegroup $user
doas usermod -G storagegroup _syncthing
- Confirm username with
- Confirm that both users are in the new shared group
id $user
id _syncthing
- See the new group on the list:
9999(storagegroup)
- Change the group ownership of /mnt to the new shared user group and give the group read / write / execute permission
doas chown -R $user:storagegroup /mnt
doas chmod 770 /mnt
- Check if Syncthing user can access /mnt
doas -u _syncthing find /mnt
- A list of directories + files in /mnt displayed — huzzah! Syncthing has access
- Restart Syncthing (to apply new permissions?)
doas rcctl restart syncthing
- Set Syncthing's default folder to /mnt
- Go to syncthing.yourdomain.com
- Go to Settings > General > Default Configuration > Edit Folder Defaults
- Under the General tab, update Folder Path to
/mnt
- Select Save
Install and set up Syncthing on my computer
- Download the Syncthing Windows Setup
- Open the .exe file and follow instructions (I didn't change any of the fields)
- Upon completion, Syncthing's web GUI opens in my browser at 127.0.0.1:8384
- Browser warns that connection is insecure (which is fine, because my localhost does not have a security certificate), so I continue to the page
- Go to Settings > GUI
- Create a new GUI Authentication User and generate a new GUI Authentication Password
- Tick the box for Use HTTPS for GUI
- Select Save
- Go to Settings > General > Default Configuration > Edit Folder Defaults
- Under the General tab, update Folder Path with preferred folder, e.g.,
D:\dump\sync
- Select Save
- Under the General tab, update Folder Path with preferred folder, e.g.,
Connect my computer to server
- Go to syncthing.yourdomain.com
- Go to This Device > Identification
- Copy the long string of characters above the QR code
- Go to 127.0.0.1:8384
- Under Remote Devices, select Add Remote Device
- Paste the long string of characters into Device ID and enter a Device Name (my server name)
- Select Save
- Go to This Device > Identification
- Copy the long string of characters above the QR code
- Go to syncthing.yourdomain.com
- Under Remote Devices, select Add Remote Device
- Paste the long string of characters into Device ID and enter a Device Name (my computer name)
- Select Save
- Both Syncthing websites update when the devices are recognized, with a green "Connected (Unused)" status next to the device names
Create a folder to sync
- Go to 127.0.0.1:8384
- Select Add Folder
- Under General
- Add a Folder Label
- Select Folder Path (a prettier Folder ID makes a prettier Folder Path, but be mindful of keeping them unique to prevent collisions)
- Select Save
- Go to Sharing > Unshared Devices
- Add a tick next to my server name
- Select Save
- Go to syncthing.yourdomain.com
- Accept the share & set up a folder on the server
- Both Syncthing websites recognize the shared folder, with a green "Up to Date" status next to the device names and folders
- Confirm things sync
- Add a hello.txt file to my computer's sync folder
- Go back to PowerShell
find /mnt
- See my hello.txt file listed
My newbie mistakes
I unmounted my /mnt storage with m-x
per the Tech Independence guide and saw this error:
umount: /mnt: Device busy
unmounted
Oops. I kind of thought this would be a bad idea and did it anyway. I live life on the edge like that.
I then tried to remount and saw this error:
/mnt: filesystem must be mounted read-only; you may need to run fsck
On syncthing.example.com, there were big yellow notices about a missing path and the shared folder had a red "Stopped" status next to its name.
So to fix this situation, I did the following:
- Stop Syncthing from running
doas rcctl stop syncthing
- Unlock the encrypted storage
doas bioctl -c C -l sd1a softraid0
- Run the file check
doas fsck /dev/sd2a
- Mark file system clean?
y
- Check what's in there
find /mnt
- Looks like all the folders & files are still in there...
- Unmount it and remount it, check that everything works as usual again
m-x
m
- Start Syncthing again
doas rcctl start syncthing
In the future, I'll stop + start Syncthing as needed:
- Before unmounting:
doas rcctl stop syncthing
- After mounting:
doas rcctl start syncthing
I will eventually figure out how to add this to the m
and m-x
shortcuts.
References
I read the following guides, documentation, and posts while learning how to do the stuff above. I also used ChatGPT to explain some stuff.
- How to install Syncthing on OpenBSD (every guide was different, so I did the stuff that was the same)
- What is my encrypted storage anyway (what's softraid?)
- The ti.sh shell script
- softraid(4)
- OpenBSD manual pages (what is all this stuff I'm typing into PowerShell?)
- Syncthing docs & forum
- Github issues & StackExchange posts